Commit f46af26a authored by Markus Poerschke's avatar Markus Poerschke

Drop support of old PHP versions and cleanup CI configurations

PHP versions that are not officially supported will not be supported by this package.
PHP 5.6 is only receiving security bugfixes. Therefore also this version won’t be supported any longer.
parent c5de15f8
filter:
excluded_paths:
- tests/*
excluded_paths:
- tests/*
tools:
php_cs_fixer: true
php_code_sniffer:
config:
standard: PSR2
php_mess_detector: true
php_analyzer: true
sensiolabs_security_checker: true
external_code_coverage:
timeout: 300
runs: 1
php_cs_fixer: true
php_code_sniffer:
config:
standard: PSR2
php_mess_detector: true
php_analyzer: true
sensiolabs_security_checker: true
external_code_coverage:
timeout: 300
runs: 1
checks:
php:
code_rating: true
duplication: true
php:
code_rating: true
duplication: true
language: php
php:
- 5.3
- 5.4
- 5.5
- 5.6
- 7.0
- 7.1
- hhvm
sudo: false
cache:
directories:
- $HOME/.composer/cache
before_script:
- composer self-update
- composer install
- travis_retry composer self-update
- travis_retry composer install --no-interaction --prefer-dist
script: ./vendor/bin/phpunit --coverage-clover=coverage.clover
script:
- ./vendor/bin/phpunit --coverage-clover=coverage.clover
after_script:
- wget https://scrutinizer-ci.com/ocular.phar
- php ocular.phar code-coverage:upload --format=php-clover coverage.clover
- travis_retry wget https://scrutinizer-ci.com/ocular.phar
- travis_retry php ocular.phar code-coverage:upload --format=php-clover coverage.clover
# Change Log
All notable changes to this project will be documented in this file.
## [Unreleased]
### Changed
- Drop support for old PHP versions: 5.3, 5.4, 5.6
## [0.11.1] - 2017-04-04
### Fixed
- All days events (no time) ends on the next day. [#83](https://github.com/markuspoerschke/iCal/pull/83)
......
......@@ -27,9 +27,12 @@
}
},
"require": {
"php": ">=5.3.0"
"php": ">=7.0"
},
"require-dev": {
"phpunit/phpunit": "~4.3"
"phpunit/phpunit": "^5.0"
},
"scripts": {
"test": "phpunit"
}
}
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment